RubyGemsのアップデート

広告

Railのインストールを行う前にRubyGemsのアップデートを行っておきます。RubyGemsとはRubyで使用されるパッケージ管理システムのことで、RailsはRubyGemsを使ってインストールします。なおRubyGemsそのものはRuby1.9系以降をお使いであれば標準で含まれています。

もし何らかの理由でRubyGemsがインストールされていない場合は「Download RubyGems | RubyGems.org | your community gem host」からインストールを行なって下さい。

それでは現在のバージョンを確認します。コマンドプロンプトを起動して頂き、次のように入力して下さい。

gem -v

p3-1

現在のバージョンは gem 2.2.2 です。

それではアップデートを行います。次のように入力して下さい。

gem update --system

p3-2

Enterキーを押して頂くと、新しいバージョンが存在する場合には次のように実行されます。

p3-3

p3-4

これでアップデートが完了しました。それでは再度バージョンを確認してみます。

p3-5

バージョンが 2.4.2 に上がっていることが確認できます。

なお最新版がインストールされている状態で先程のコマンドを実行すると次のように表示されます。

p3-6

RubyGemsのアップデートは以上です。

( Written by Tatsuo Ikura )

関連記事 (一部広告含む)